$re = '/^(?:(?:[0-9]|1[0-9]|2[0-4])(?:\.[0-9])?|25(?:\.)?)$/m';
$str = '2
2.5
23.0
8
24.3
25
25.0
0.01
-1
25.00
26';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);