const regex = /^(?:(?:[0-9]|1[0-9]|2[0-4])(?:\.[0-9])?|25(?:\.)?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[0-9]|1[0-9]|2[0-4])(?:\\.[0-9])?|25(?:\\.)?)$', 'gm')
const str = `2
2.5
23.0
8
24.3
25
25.0
0.01
-1
25.00
26`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}