using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S*\s){4}(?<findstring>.*)";
string input = @"апавп лопавр рплап парпар смирап апрапро рпор лпр прор 56 апроп, арпр аврпв";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}