re = /^(\S*\s){4}(?<findstring>.*)/m
str = 'апавп лопавр рплап парпар смирап апрапро рпор лпр прор 56 апроп, арпр аврпв'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end