// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\S*\s){4}(?<findstring>.*)").unwrap();
let string = "апавп лопавр рплап парпар смирап апрапро рпор лпр прор 56 апроп, арпр аврпв";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}