import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)<\\/?\\w+[^>]*>(*SKIP)(?!)|\\b([a-z])\\b";
final String string = "\"hello, this is a <a href=\"example.com\">beautiful day</a>\"";
final String subst = "\\1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}