$re = '/(?i)<\/?\w+[^>]*>(*SKIP)(?!)|\b([a-z])\b/m';
$str = '"hello, this is a <a href="example.com">beautiful day</a>"';
$subst = "\1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;