import re
regex = re.compile(r"(?i)<\/?\w+[^>]*>(*SKIP)(?!)|\b([a-z])\b", flags=re.MULTILINE)
test_str = "\"hello, this is a <a href=\"example.com\">beautiful day</a>\""
subst = "\\1 "
result = regex.sub(subst, test_str)
if result:
print(result)