const regex = /(?i)<\/?\w+[^>]*>(*SKIP)(?!)|\b([a-z])\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)<\\\/?\\w+[^>]*>(*SKIP)(?!)|\\b([a-z])\\b', 'gm')
const str = `"hello, this is a <a href="example.com">beautiful day</a>"`;
const subst = `\1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);