#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"(?!(\{\{[^\s]*\}\}\s*)+").*""
Local $sString = "var yes = "test";" & @CRLF & _
"var nope = "{{xyz}}";" & @CRLF & _
"var yes = "test {{xyz}}";" & @CRLF & _
"var yes = "{test";" & @CRLF & _
"var yes = "{test} bearbeiten";" & @CRLF & _
"var yes = "{test}";" & @CRLF & _
"var nope = "{{::xyz}}";" & @CRLF & _
"var nope = "{{xyz}} {{abc}}";" & @CRLF & _
"var yes = "{{xyz}} test {{abc}}";" & @CRLF & _
"var yes = "{{xyz}} test {{abc}} temp {{var}}";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")