import re
regex = re.compile(r"\"(?!(\{\{[^\s]*\}\}\s*)+\").*\"", flags=re.MULTILINE)
test_str = ("var yes = \"test\";\n"
"var nope = \"{{xyz}}\";\n"
"var yes = \"test {{xyz}}\";\n"
"var yes = \"{test\";\n"
"var yes = \"{test} bearbeiten\";\n"
"var yes = \"{test}\";\n"
"var nope = \"{{::xyz}}\";\n"
"var nope = \"{{xyz}} {{abc}}\";\n"
"var yes = \"{{xyz}} test {{abc}}\";\n"
"var yes = \"{{xyz}} test {{abc}} temp {{var}}\";")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")