using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?!(\{\{[^\s]*\}\}\s*)+"").*""";
string input = @"var yes = ""test"";
var nope = ""{{xyz}}"";
var yes = ""test {{xyz}}"";
var yes = ""{test"";
var yes = ""{test} bearbeiten"";
var yes = ""{test}"";
var nope = ""{{::xyz}}"";
var nope = ""{{xyz}} {{abc}}"";
var yes = ""{{xyz}} test {{abc}}"";
var yes = ""{{xyz}} test {{abc}} temp {{var}}"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}