import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?!(\\{\\{[^\\s]*\\}\\}\\s*)+\").*\"";
final String string = "var yes = \"test\";\n"
+ "var nope = \"{{xyz}}\";\n"
+ "var yes = \"test {{xyz}}\";\n"
+ "var yes = \"{test\";\n"
+ "var yes = \"{test} bearbeiten\";\n"
+ "var yes = \"{test}\";\n"
+ "var nope = \"{{::xyz}}\";\n"
+ "var nope = \"{{xyz}} {{abc}}\";\n"
+ "var yes = \"{{xyz}} test {{abc}}\";\n"
+ "var yes = \"{{xyz}} test {{abc}} temp {{var}}\";";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}