re = /"(?!(\{\{[^\s]*\}\}\s*)+").*"/m
str = 'var yes = "test";
var nope = "{{xyz}}";
var yes = "test {{xyz}}";
var yes = "{test";
var yes = "{test} bearbeiten";
var yes = "{test}";
var nope = "{{::xyz}}";
var nope = "{{xyz}} {{abc}}";
var yes = "{{xyz}} test {{abc}}";
var yes = "{{xyz}} test {{abc}} temp {{var}}";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end