#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"(?:" & @CRLF & _
" (?:(?=\D*\d)(?=[^a-z]*[a-z]))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=\D*\d)(?=[^!?€%&]*[!?€%&]))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=\D*\d)(?=[^A-Z]*[A-Z]))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=[^a-z]*[a-z])(?=[^!?€%&]*[!?€%&]))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z]))" & @CRLF & _
" |" & @CRLF & _
" (?:(?=[^!?€%&]*[!?€%&])(?=[^A-Z]*[A-Z]))" & @CRLF & _
")" & @CRLF & _
".+" & @CRLF & _
"$"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"1 digit" & @CRLF & _
"1 lowercase character" & @CRLF & _
"1 special character (!?€%&, etc)" & @CRLF & _
"1 uppercase character" & @CRLF & _
"" & @CRLF & _
"1A"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")