import Foundation
let pattern = #"""
^
(?:
(?:(?=\D*\d)(?=[^a-z]*[a-z]))
|
(?:(?=\D*\d)(?=[^!?€%&]*[!?€%&]))
|
(?:(?=\D*\d)(?=[^A-Z]*[A-Z]))
|
(?:(?=[^a-z]*[a-z])(?=[^!?€%&]*[!?€%&]))
|
(?:(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z]))
|
(?:(?=[^!?€%&]*[!?€%&])(?=[^A-Z]*[A-Z]))
)
.+
$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
1 digit
1 lowercase character
1 special character (!?€%&, etc)
1 uppercase character
1A
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)