import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?:\n"
+ " (?:(?=\\D*\\d)(?=[^a-z]*[a-z]))\n"
+ " |\n"
+ " (?:(?=\\D*\\d)(?=[^!?€%&]*[!?€%&]))\n"
+ " |\n"
+ " (?:(?=\\D*\\d)(?=[^A-Z]*[A-Z]))\n"
+ " |\n"
+ " (?:(?=[^a-z]*[a-z])(?=[^!?€%&]*[!?€%&]))\n"
+ " |\n"
+ " (?:(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z]))\n"
+ " |\n"
+ " (?:(?=[^!?€%&]*[!?€%&])(?=[^A-Z]*[A-Z]))\n"
+ ")\n"
+ ".+\n"
+ "$";
final String string = "\n\n"
+ "1 digit\n"
+ "1 lowercase character\n"
+ "1 special character (!?€%&, etc)\n"
+ "1 uppercase character\n\n"
+ "1A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}