// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?:
(?:(?=\D*\d)(?=[^a-z]*[a-z]))
|
(?:(?=\D*\d)(?=[^!?€%&]*[!?€%&]))
|
(?:(?=\D*\d)(?=[^A-Z]*[A-Z]))
|
(?:(?=[^a-z]*[a-z])(?=[^!?€%&]*[!?€%&]))
|
(?:(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z]))
|
(?:(?=[^!?€%&]*[!?€%&])(?=[^A-Z]*[A-Z]))
)
.+
$").unwrap();
let string = "
1 digit
1 lowercase character
1 special character (!?€%&, etc)
1 uppercase character
1A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}