package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\s*(\d*)(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?\]`)
var str = `aspdfoijaspdfaf [1, 2, 3] in text [1,2] or [1,3,5,23]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}