// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\s*(\d*)(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?\]").unwrap();
let string = "aspdfoijaspdfaf [1, 2, 3] in text [1,2] or [1,3,5,23]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}