import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\s*(\\d*)(\\s*,\\s*(\\d*)\\s*)?(\\s*,\\s*(\\d*)\\s*)?(\\s*,\\s*(\\d*)\\s*)?(\\s*,\\s*(\\d*)\\s*)?(\\s*,\\s*(\\d*)\\s*)?(\\s*,\\s*(\\d*)\\s*)?\\]";
final String string = "aspdfoijaspdfaf [1, 2, 3] in text [1,2] or [1,3,5,23]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}