const regex = new RegExp('\\[\\s*(\\d*)(\\s*,\\s*(\\d*)\\s*)?(\\s*,\\s*(\\d*)\\s*)?(\\s*,\\s*(\\d*)\\s*)?(\\s*,\\s*(\\d*)\\s*)?(\\s*,\\s*(\\d*)\\s*)?(\\s*,\\s*(\\d*)\\s*)?\\]', 'mg')
const str = `aspdfoijaspdfaf [1, 2, 3] in text [1,2] or [1,3,5,23]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}