re = /\[\s*(\d*)(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?(\s*,\s*(\d*)\s*)?\]/m
str = 'aspdfoijaspdfaf [1, 2, 3] in text [1,2] or [1,3,5,23]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end