import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\?id=([^&]+)";
final String string = "http://video.nhl.com/videocenter/console?id=789500&catid=35\n"
+ "http://video.senators.nhl.com/videocenter/console?id=790130&catid=1141\n"
+ "http://video.nhl.com/videocenter/?id=2013020884-605-h";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}