use strict;
my $str = 'http://video.nhl.com/videocenter/console?id=789500&catid=35
http://video.senators.nhl.com/videocenter/console?id=790130&catid=1141
http://video.nhl.com/videocenter/?id=2013020884-605-h';
my $regex = qr/\?id=([^&]+)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}