import re
regex = re.compile(r"\?id=([^&]+)", flags=re.IGNORECASE)
test_str = ("http://video.nhl.com/videocenter/console?id=789500&catid=35\n"
"http://video.senators.nhl.com/videocenter/console?id=790130&catid=1141\n"
"http://video.nhl.com/videocenter/?id=2013020884-605-h")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")