re = /\?id=([^&]+)/i
str = 'http://video.nhl.com/videocenter/console?id=789500&catid=35
http://video.senators.nhl.com/videocenter/console?id=790130&catid=1141
http://video.nhl.com/videocenter/?id=2013020884-605-h'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end