const regex = /\?id=([^&]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\?id=([^&]+)', 'gi')
const str = `http://video.nhl.com/videocenter/console?id=789500&catid=35
http://video.senators.nhl.com/videocenter/console?id=790130&catid=1141
http://video.nhl.com/videocenter/?id=2013020884-605-h`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}