using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?:
<
(?: p | li )
\b
[^>]*? color \s* : \s*
(?:
( black ) # (1)
# | transparent
)
[^>]*? >
# (?(1)
(?: \s* <span \b [^>]*? > )?
#)
|
<span \b
[^>]*? color \s* : \s* black [^>]*? >
)
(?s)
\s* <code \b
(?: "".*?"" | '.*?' | [^>]*? )+ >
(*SKIP) (*FAIL)
|
<code \b
[^>]*? style [^>]*? background-color \s* : \s* transparent [^>]*? >";
string input = @"<p....color: black...> <span.......>
<code style=""background-color: transparent;"">
<p....color: black...>
<code style=""background-color: transparent;"">
<p....color: transparent...>
<code style=""background-color: transparent;"">
<span....color: black...>
<code style=""background-color: transparent;"">
<li style....color: black...> <span....color: black...>
<code style=""background-color: transparent;"">
<li style....color: black...>
<code>
<li style....color: black...> <span......>
<code style=""background-color: transparent;"">
<code style=""background-color: transparent;"">
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}