$re = '~ (?:
<
(?: p | li )
\b
[^>]*? color \s* : \s*
(?:
( black ) # (1)
# | transparent
)
[^>]*? >
# (?(1)
(?: \s* <span \b [^>]*? > )?
#)
|
<span \b
[^>]*? color \s* : \s* black [^>]*? >
)
(?s)
\s* <code \b
(?: ".*?" | \'.*?\' | [^>]*? )+ >
(*SKIP) (*FAIL)
|
<code \b
[^>]*? style [^>]*? background-color \s* : \s* transparent [^>]*? >~x';
$str = '<p....color: black...> <span.......>
<code style="background-color: transparent;">
<p....color: black...>
<code style="background-color: transparent;">
<p....color: transparent...>
<code style="background-color: transparent;">
<span....color: black...>
<code style="background-color: transparent;">
<li style....color: black...> <span....color: black...>
<code style="background-color: transparent;">
<li style....color: black...>
<code>
<li style....color: black...> <span......>
<code style="background-color: transparent;">
<code style="background-color: transparent;">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);