# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:
<
(?: p | li )
\b
[^>]*? color \s* : \s*
(?:
( black ) # (1)
# | transparent
)
[^>]*? >
# (?(1)
(?: \s* <span \b [^>]*? > )?
#)
|
<span \b
[^>]*? color \s* : \s* black [^>]*? >
)
(?s)
\s* <code \b
(?: ".*?" | '.*?' | [^>]*? )+ >
(*SKIP) (*FAIL)
|
<code \b
[^>]*? style [^>]*? background-color \s* : \s* transparent [^>]*? >
"""
test_str = ("<p....color: black...> <span.......>\n"
"<code style=\"background-color: transparent;\">\n\n"
"<p....color: black...>\n"
"<code style=\"background-color: transparent;\">\n\n"
"<p....color: transparent...>\n"
"<code style=\"background-color: transparent;\">\n\n"
"<span....color: black...>\n"
"<code style=\"background-color: transparent;\">\n\n"
"<li style....color: black...> <span....color: black...>\n"
"<code style=\"background-color: transparent;\">\n\n"
"<li style....color: black...>\n"
"<code>\n\n"
"<li style....color: black...> <span......>\n"
"<code style=\"background-color: transparent;\">\n\n"
"<code style=\"background-color: transparent;\">\n")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.