use strict;
my $str = '<p....color: black...> <span.......>
<code style="background-color: transparent;">
<p....color: black...>
<code style="background-color: transparent;">
<p....color: transparent...>
<code style="background-color: transparent;">
<span....color: black...>
<code style="background-color: transparent;">
<li style....color: black...> <span....color: black...>
<code style="background-color: transparent;">
<li style....color: black...>
<code>
<li style....color: black...> <span......>
<code style="background-color: transparent;">
<code style="background-color: transparent;">
';
my $regex = qr~ (?:
<
(?: p | li )
\b
[^>]*? color \s* : \s*
(?:
( black ) # (1)
# | transparent
)
[^>]*? >
# (?(1)
(?: \s* <span \b [^>]*? > )?
#)
|
<span \b
[^>]*? color \s* : \s* black [^>]*? >
)
(?s)
\s* <code \b
(?: ".*?" | '.*?' | [^>]*? )+ >
(*SKIP) (*FAIL)
|
<code \b
[^>]*? style [^>]*? background-color \s* : \s* transparent [^>]*? >~xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}