package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` (?:
<
(?: p | li )
\b
[^>]*? color \s* : \s*
(?:
( black ) # (1)
# | transparent
)
[^>]*? >
# (?(1)
(?: \s* <span \b [^>]*? > )?
#)
|
<span \b
[^>]*? color \s* : \s* black [^>]*? >
)
(?s)
\s* <code \b
(?: ".*?" | '.*?' | [^>]*? )+ >
(*SKIP) (*FAIL)
|
<code \b
[^>]*? style [^>]*? background-color \s* : \s* transparent [^>]*? >`)
var str = `<p....color: black...> <span.......>
<code style="background-color: transparent;">
<p....color: black...>
<code style="background-color: transparent;">
<p....color: transparent...>
<code style="background-color: transparent;">
<span....color: black...>
<code style="background-color: transparent;">
<li style....color: black...> <span....color: black...>
<code style="background-color: transparent;">
<li style....color: black...>
<code>
<li style....color: black...> <span......>
<code style="background-color: transparent;">
<code style="background-color: transparent;">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}