using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w]{2}\s[\d]{2}\.\s[\w]+\s[\d]{4}\s[\d]{2}\:[\d]{2}\s[\w]+";
string input = @"Am 16. Juli 2014 19:55 schrieb";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}