const regex = /[\w]{2}\s[\d]{2}\.\s[\w]+\s[\d]{4}\s[\d]{2}\:[\d]{2}\s[\w]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w]{2}\\s[\\d]{2}\\.\\s[\\w]+\\s[\\d]{4}\\s[\\d]{2}\\:[\\d]{2}\\s[\\w]+', '')
const str = `Am 16. Juli 2014 19:55 schrieb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}