import Foundation
let pattern = #"[\w]{2}\s[\d]{2}\.\s[\w]+\s[\d]{4}\s[\d]{2}\:[\d]{2}\s[\w]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Am 16. Juli 2014 19:55 schrieb"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}