$re = '/[\w]{2}\s[\d]{2}\.\s[\w]+\s[\d]{4}\s[\d]{2}\:[\d]{2}\s[\w]+/';
$str = 'Am 16. Juli 2014 19:55 schrieb';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);