re = /[\w]{2}\s[\d]{2}\.\s[\w]+\s[\d]{4}\s[\d]{2}\:[\d]{2}\s[\w]+/
str = 'Am 16. Juli 2014 19:55 schrieb'
# Print the match result
str.match(re) do |match|
puts match.to_s
end