# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d{5})-(\d{7})-$/$1-$2/gm;t' <<< "11111-2222222-
11111-2222222-3"