package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{5})-(\d{7})-$`)
var str = `11111-2222222-
11111-2222222-3`
var substitution = "$1-$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}