#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{5})-(\d{7})-$"
Local $sString = "11111-2222222-" & @CRLF & _
"11111-2222222-3"
Local $sSubst = "$1-$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)