use strict;
my $str = '11111-2222222-
11111-2222222-3';
my $regex = qr/^(\d{5})-(\d{7})-$/mp;
my $subst = '$1-$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";