$re = '/^(\d{5})-(\d{7})-$/m';
$str = '11111-2222222-
11111-2222222-3';
$subst = "$1-$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;