using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<.[^>]*>(\s+|()|( )*|\s+( )*|( )*\s+|\s+( )*\s+)<\/.[^>]*>";
string input = @"<p></p>
<p> </p>
<b>
</b>
<B></B>
<i> </i>
<i> </i>
<i> </i>
<strong></strong>
<i style=""color: orange""></i>
<a href=""#""> </a>
<o: class=""ms-crap""></o>
<p>Not empty</p>
<p>Not
empty</p>
<i>
</i>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}