re = /<.[^>]*>(\s+|()|( )*|\s+( )*|( )*\s+|\s+( )*\s+)<\/.[^>]*>/i
str = '<p></p>
<p> </p>
<b>
</b>
<B></B>
<i> </i>
<i> </i>
<i> </i>
<strong></strong>
<i style="color: orange"></i>
<a href="#"> </a>
<o: class="ms-crap"></o>
<p>Not empty</p>
<p>Not
empty</p>
<i>
</i>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end