import re
regex = re.compile(r"<.[^>]*>(\s+|()|( )*|\s+( )*|( )*\s+|\s+( )*\s+)<\/.[^>]*>", flags=re.IGNORECASE)
test_str = ("<p></p>\n"
"<p> </p>\n"
"<b>\n"
" \n"
" </b> \n"
"<B></B>\n"
"<i> </i>\n"
"<i> </i>\n"
"<i> </i>\n"
"<strong></strong>\n"
"<i style=\"color: orange\"></i>\n"
"<a href=\"#\"> </a>\n"
"<o: class=\"ms-crap\"></o>\n\n"
"<p>Not empty</p>\n"
"<p>Not \n"
" empty</p>\n"
"<i> \n\n"
" </i>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")