import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<.[^>]*>(\\s+|()|( )*|\\s+( )*|( )*\\s+|\\s+( )*\\s+)<\\/.[^>]*>";
final String string = "<p></p>\n"
+ "<p> </p>\n"
+ "<b>\n"
+ " \n"
+ " </b> \n"
+ "<B></B>\n"
+ "<i> </i>\n"
+ "<i> </i>\n"
+ "<i> </i>\n"
+ "<strong></strong>\n"
+ "<i style=\"color: orange\"></i>\n"
+ "<a href=\"#\"> </a>\n"
+ "<o: class=\"ms-crap\"></o>\n\n"
+ "<p>Not empty</p>\n"
+ "<p>Not \n"
+ " empty</p>\n"
+ "<i> \n\n"
+ " </i>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}