use strict;
my $str = '<p></p>
<p> </p>
<b>
</b>
<B></B>
<i> </i>
<i> </i>
<i> </i>
<strong></strong>
<i style="color: orange"></i>
<a href="#"> </a>
<o: class="ms-crap"></o>
<p>Not empty</p>
<p>Not
empty</p>
<i>
</i>
';
my $regex = qr/<.[^>]*>(\s+|()|( )*|\s+( )*|( )*\s+|\s+( )*\s+)<\/.[^>]*>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}