#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(man)|[^0-9]"
Local $sString = "012345m67890man"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)