using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(man)|[^0-9]";
string substitution = @"$1";
string input = @"012345m67890man";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}